WP 2.5 Arrr! (or just Upgrades in general)

Well its taken some time, but finally managed to update 2.5(.1) – quite a while ago changed to upgrade via SVN which makes updating (usually) a dream, but not getting to 2.5.

No idea why, but the simple

svn sw http://svn.automattic.com/wordpress/tags/2.5/

Just didnt cut it,

PHP Fatal error: Cannot redeclare get_tag_feed_link() (previously declared in wp-includes/link-template.php:384) in wp-includes/feed.php on line 211
PHP Fatal error: Call to undefined function absint() in wp-includes/query.php on line 1346

etc. It seems it simply didn’t update all the files?

So back to basics, and doing a fresh install of 2.5 and installing my stuff into it (just like the first time setting up SVN) – now the working copy switches to 2.5.1 without issue!

Anyway, now have 2.5 running – quite like it, the admin is certainly more responsive, not sure of new features yet, dont tend to push WP that much.

Oh and then upgrading plugins, somewhere along the line Akismet got conflicted? Zapping it and checking it out again fixed that. Then Geopress, thought it would make sence to switch to using SVN for that, and found the/a repositoity, but that only gives me 2.4.1, whereas this suggests 2.4.3?? I guess that repro is either outdated or abandoned? Also this page is borked.

[Update: just noticed the KML output from GeoPress doesn't work - installed 2.4.3 in the end too, but seeing as I wrote the KML code, I guess its my responsibilty to fix - will work on that!]

[Update2: The correct geopress repro location is here - thanks to Andrew in comments!]

Anyway at least it now done (for now)

Tags: , , ,

3 Responses to “WP 2.5 Arrr! (or just Upgrades in general)”

  1. Thanks for pointing out the problem with the GeoRSS.org page. Seems to be a problem with pretty-url rewrite.

    GeoPress is being checked in parallel to the WordPress plugins repository. By doing this, new releases automatically get packaged and updates in the WordPress repository.

    SVN: http://svn.wp-plugins.org/geopress/trunk

    WordPress GeoPress Page: http://wordpress.org/extend/plugins/geopress/

    It has been upgraded to work with WP 2.5. Definitely let me know if something else is odd.


  2. Thomas Wood says:

    My upgrades of WP with SVN from ~2.4.ish have gone without a hitch.
    I first installed GeoPress with 2.5 last month, and tbh am not very impressed with it.
    I might try the trunk version to see if its any better.
    I had intended on hacking on it a bit, but since I only actually bother blogging once a month, it seemed pointless.

  3. Barry says:

    Thanks Andrew for pointing me towards the correct repro, will relocate :) . Sorry also for the ‘lazyweb’ of notifing about the page problem, guess was just frustrated with all the updating woos.

    Yes no idea Thomas why mine failed, see many posts around the web of successfully upgrading to 2.5 via SVN. I’ve never even modified anything in the wp-includes folder, so its not a messed up merge.